We're investigating an issue where email notifications from EnjoyHQ are being delayed
Incident Report for EnjoyHQ
Resolved
We have released a fix for the issue we apologise for the inconvenience.
Posted Oct 04, 2024 - 10:14 UTC
Update
We are continuing to investigate this issue.
Posted Oct 03, 2024 - 17:33 UTC
Investigating
We are currently investigating this issue.
Posted Oct 03, 2024 - 17:32 UTC
This incident affected: Application.